// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\n+\s*\<").unwrap();
let string = "FIRST LINE '<foo>
<bar>
<baz>'
ANOTHER LINE 'lorem ipsim', '<dolor>
<and>
<p>again</p>
</and>
</dolor>'
Expected:
FIRST LINE '<foo> <bar><baz>'
ANOTHER LINE 'lorem ipsim', '<dolor><and><p>again</p></and><dolor>'";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}