#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)O(?<=^.{0,8})"
Local $sString = "C099900XABCD" & @CRLF & _
"" & @CRLF & _
"O099900XABCD" & @CRLF & _
"CO99900XABCD" & @CRLF & _
"C0O9900XABCD" & @CRLF & _
"C09O900XABCD" & @CRLF & _
"C099O00XABCD" & @CRLF & _
"C0999O0XABCD" & @CRLF & _
"C09990OXABCD" & @CRLF & _
"C099900OABCD" & @CRLF & _
"" & @CRLF & _
"C099900XOBCD" & @CRLF & _
"C099900XAOCD" & @CRLF & _
"C099900XABOD" & @CRLF & _
"C099900XABCO"
Local $sSubst = "0"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)