$re = '/O(?<=^.{0,8})/m';
$str = 'C099900XABCD
O099900XABCD
CO99900XABCD
C0O9900XABCD
C09O900XABCD
C099O00XABCD
C0999O0XABCD
C09990OXABCD
C099900OABCD
C099900XOBCD
C099900XAOCD
C099900XABOD
C099900XABCO';
$subst = "0";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;