import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "O(?<=^.{0,8})";
final String string = "C099900XABCD\n\n"
+ "O099900XABCD\n"
+ "CO99900XABCD\n"
+ "C0O9900XABCD\n"
+ "C09O900XABCD\n"
+ "C099O00XABCD\n"
+ "C0999O0XABCD\n"
+ "C09990OXABCD\n"
+ "C099900OABCD\n\n"
+ "C099900XOBCD\n"
+ "C099900XAOCD\n"
+ "C099900XABOD\n"
+ "C099900XABCO";
final String subst = "0";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}