const regex = /O(?<=^.{0,8})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('O(?<=^.{0,8})', 'gm')
const str = `C099900XABCD
O099900XABCD
CO99900XABCD
C0O9900XABCD
C09O900XABCD
C099O00XABCD
C0999O0XABCD
C09990OXABCD
C099900OABCD
C099900XOBCD
C099900XAOCD
C099900XABOD
C099900XABCO`;
const subst = `0`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);