import re
regex = re.compile(r"O(?<=^.{0,8})", flags=re.MULTILINE)
test_str = ("C099900XABCD\n\n"
"O099900XABCD\n"
"CO99900XABCD\n"
"C0O9900XABCD\n"
"C09O900XABCD\n"
"C099O00XABCD\n"
"C0999O0XABCD\n"
"C09990OXABCD\n"
"C099900OABCD\n\n"
"C099900XOBCD\n"
"C099900XAOCD\n"
"C099900XABOD\n"
"C099900XABCO")
subst = "0"
result = regex.sub(subst, test_str)
if result:
print(result)