#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(---[\s\S]*?)(cover:\s*")(!\[\[|\[\[)([^|\]]+)(\|[^\]]*)?(\]\]")([\s\S]*?---)"
Local $sString = "---" & @CRLF & _
"created: 1" & @CRLF & _
"tags: 2" & @CRLF & _
"cover: "![[一Attachments/47c4ec6d8e8816ce75f120a264f4130a_MD5.jpg]]"" & @CRLF & _
"url: 3" & @CRLF & _
"---" & @CRLF & _
"" & @CRLF & _
"---" & @CRLF & _
"created: 1" & @CRLF & _
"tags: 2" & @CRLF & _
"cover: "[[一Attachments/47c4ec6d8e8816ce75f120a264f4130a_MD5.jpg]]"" & @CRLF & _
"url: 3" & @CRLF & _
"---" & @CRLF & _
"" & @CRLF & _
"---" & @CRLF & _
"created: 1" & @CRLF & _
"tags: 2" & @CRLF & _
"cover: "![[一Attachments/47c4ec6d8e8816ce75f120a264f4130a_MD5.jpg|^]]"" & @CRLF & _
"url: 3" & @CRLF & _
"---"
Local $sSubst = "$1$2[[$4|^]]"$7"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)