use strict;
my $str = '---
created: 1
tags: 2
cover: "![[一Attachments/47c4ec6d8e8816ce75f120a264f4130a_MD5.jpg]]"
url: 3
---
---
created: 1
tags: 2
cover: "[[一Attachments/47c4ec6d8e8816ce75f120a264f4130a_MD5.jpg]]"
url: 3
---
---
created: 1
tags: 2
cover: "![[一Attachments/47c4ec6d8e8816ce75f120a264f4130a_MD5.jpg|^]]"
url: 3
---';
my $regex = qr/(---[\s\S]*?)(cover:\s*")(!\[\[|\[\[)([^|\]]+)(\|[^\]]*)?(\]\]")([\s\S]*?---)/mp;
my $subst = '$1$2[[$4|^]]"$7';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";