$re = '/(---[\s\S]*?)(cover:\s*")(!\[\[|\[\[)([^|\]]+)(\|[^\]]*)?(\]\]")([\s\S]*?---)/m';
$str = '---
created: 1
tags: 2
cover: "![[一Attachments/47c4ec6d8e8816ce75f120a264f4130a_MD5.jpg]]"
url: 3
---
---
created: 1
tags: 2
cover: "[[一Attachments/47c4ec6d8e8816ce75f120a264f4130a_MD5.jpg]]"
url: 3
---
---
created: 1
tags: 2
cover: "![[一Attachments/47c4ec6d8e8816ce75f120a264f4130a_MD5.jpg|^]]"
url: 3
---';
$subst = "$1$2[[$4|^]]\"$7";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;