# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(---[\s\S]*?)(cover:\s*\")(!\[\[|\[\[)([^|\]]+)(\|[^\]]*)?(\]\]\")([\s\S]*?---)"
test_str = ("---\n"
"created: 1\n"
"tags: 2\n"
"cover: \"![[一Attachments/47c4ec6d8e8816ce75f120a264f4130a_MD5.jpg]]\"\n"
"url: 3\n"
"---\n\n"
"---\n"
"created: 1\n"
"tags: 2\n"
"cover: \"[[一Attachments/47c4ec6d8e8816ce75f120a264f4130a_MD5.jpg]]\"\n"
"url: 3\n"
"---\n\n"
"---\n"
"created: 1\n"
"tags: 2\n"
"cover: \"![[一Attachments/47c4ec6d8e8816ce75f120a264f4130a_MD5.jpg|^]]\"\n"
"url: 3\n"
"---")
subst = "$1$2[[$4|^]]\"$7"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.