package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(---[\s\S]*?)(cover:\s*")(!\[\[|\[\[)([^|\]]+)(\|[^\]]*)?(\]\]")([\s\S]*?---)`)
var str = `---
created: 1
tags: 2
cover: "![[一Attachments/47c4ec6d8e8816ce75f120a264f4130a_MD5.jpg]]"
url: 3
---
---
created: 1
tags: 2
cover: "[[一Attachments/47c4ec6d8e8816ce75f120a264f4130a_MD5.jpg]]"
url: 3
---
---
created: 1
tags: 2
cover: "![[一Attachments/47c4ec6d8e8816ce75f120a264f4130a_MD5.jpg|^]]"
url: 3
---`
var substitution = "$1$2[[$4|^]]"$7"
fmt.Println(re.ReplaceAllString(str, substitution))
}