using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(---[\s\S]*?)(cover:\s*"")(!\[\[|\[\[)([^|\]]+)(\|[^\]]*)?(\]\]"")([\s\S]*?---)";
string substitution = @"$1$2[[$4|^]]""$7";
string input = @"---
created: 1
tags: 2
cover: ""![[一Attachments/47c4ec6d8e8816ce75f120a264f4130a_MD5.jpg]]""
url: 3
---
---
created: 1
tags: 2
cover: ""[[一Attachments/47c4ec6d8e8816ce75f120a264f4130a_MD5.jpg]]""
url: 3
---
---
created: 1
tags: 2
cover: ""![[一Attachments/47c4ec6d8e8816ce75f120a264f4130a_MD5.jpg|^]]""
url: 3
---";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}