using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[22-99]{2}[A-Z]{2}[0-9]{4}[A-Z]{2}[0-9A-Z]{1}[0-9]{5}[A-Z]{1}[0-9]{1}";
string input = @"22DE4701AEM15487R1
22DE4701BB025132C5
23DE3302CEA45678R6
23DE7650EEH54214R9
23DE6150APH12542R3
23DE6150KFA21587R7
22DE6150JHM36859R8
23DE4701DCA12345R4
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}