re = /[22-99]{2}[A-Z]{2}[0-9]{4}[A-Z]{2}[0-9A-Z]{1}[0-9]{5}[A-Z]{1}[0-9]{1}/m
str = '22DE4701AEM15487R1
22DE4701BB025132C5
23DE3302CEA45678R6
23DE7650EEH54214R9
23DE6150APH12542R3
23DE6150KFA21587R7
22DE6150JHM36859R8
23DE4701DCA12345R4
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end