// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[22-99]{2}[A-Z]{2}[0-9]{4}[A-Z]{2}[0-9A-Z]{1}[0-9]{5}[A-Z]{1}[0-9]{1}").unwrap();
let string = "22DE4701AEM15487R1
22DE4701BB025132C5
23DE3302CEA45678R6
23DE7650EEH54214R9
23DE6150APH12542R3
23DE6150KFA21587R7
22DE6150JHM36859R8
23DE4701DCA12345R4
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}