import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[22-99]{2}[A-Z]{2}[0-9]{4}[A-Z]{2}[0-9A-Z]{1}[0-9]{5}[A-Z]{1}[0-9]{1}";
final String string = "22DE4701AEM15487R1\n"
+ "22DE4701BB025132C5\n"
+ "23DE3302CEA45678R6\n"
+ "23DE7650EEH54214R9\n"
+ "23DE6150APH12542R3\n"
+ "23DE6150KFA21587R7\n"
+ "22DE6150JHM36859R8\n"
+ "23DE4701DCA12345R4\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}