import re
regex = re.compile(r"[22-99]{2}[A-Z]{2}[0-9]{4}[A-Z]{2}[0-9A-Z]{1}[0-9]{5}[A-Z]{1}[0-9]{1}", flags=re.MULTILINE)
test_str = ("22DE4701AEM15487R1\n"
"22DE4701BB025132C5\n"
"23DE3302CEA45678R6\n"
"23DE7650EEH54214R9\n"
"23DE6150APH12542R3\n"
"23DE6150KFA21587R7\n"
"22DE6150JHM36859R8\n"
"23DE4701DCA12345R4\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")