# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^\s+|\s+$|\s+(?=\s)(?=(?:[^\"]*\"[^\"]*\")*[^\"]*$)//g;t' <<< " Lorem ipsum dolor sit amet, consectetur adipiscing elit. Quisque sagittis semper ipsum at consectetur.
Fusce mauris \" don't modify the space between quotes like this \" massa, elementum id neque vel, facilisis ultrices enim. "