import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\s+|\\s+$|\\s+(?=\\s)(?=(?:[^\\\"]*\\\"[^\\\"]*\\\")*[^\\\"]*$)";
final String string = " Lorem ipsum dolor sit amet, consectetur adipiscing elit. Quisque sagittis semper ipsum at consectetur.\n"
+ "Fusce mauris \" don't modify the space between quotes like this \" massa, elementum id neque vel, facilisis ultrices enim. ";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}