import Foundation
let pattern = #"^\s+|\s+$|\s+(?=\s)(?=(?:[^\"]*\"[^\"]*\")*[^\"]*$)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Lorem ipsum dolor sit amet, consectetur adipiscing elit. Quisque sagittis semper ipsum at consectetur.
Fusce mauris " don't modify the space between quotes like this " massa, elementum id neque vel, facilisis ultrices enim.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)