re = /^\s+|\s+$|\s+(?=\s)(?=(?:[^\"]*\"[^\"]*\")*[^\"]*$)/
str = ' Lorem ipsum dolor sit amet, consectetur adipiscing elit. Quisque sagittis semper ipsum at consectetur.
Fusce mauris " don\'t modify the space between quotes like this " massa, elementum id neque vel, facilisis ultrices enim. '
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result