package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)(?:^[ \t]*(?P<complete>x))|
(?P<priority>\(\w+\))|
(?:(?P<CoDate>\d{4}-\d\d-\d\d)[ \t]*(?P<CrDate>\d{4}-\d\d-\d\d)?)|
(?P<task>[\w']+(?:[.,; \t-]+[\w']+)*\b(?!:))|
(?P<Project>\+\w+)|
(?P<context>@\w+)|
(?P<meta>[a-zA-Z]+:[\w-]*)`)
var str = `(A) Thank Mom for the meatballs @phone
(B) Schedule Goodwill pickup +GarageSale @phone
Post signs around the neighborhood +GarageSale
@GroceryStore Eskimo pies
Really gotta call Mom (A) @phone @someday
(b) Get back to the boss
(B) Submit TPS report
x 2011-03-03 Call Mom due:2010-01-02 again:thisOne
x 2011-03-02 2011-03-01 Review Tim's pull request +TodoTxtTouch @github
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}