import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:^[ \\t]*(?P<complete>x))|\n"
+ "(?P<priority>\\(\\w+\\))|\n"
+ "(?:(?P<CoDate>\\d{4}-\\d\\d-\\d\\d)[ \\t]*(?P<CrDate>\\d{4}-\\d\\d-\\d\\d)?)|\n"
+ "(?P<task>[\\w']+(?:[.,; \\t-]+[\\w']+)*\\b(?!:))|\n"
+ "(?P<Project>\\+\\w+)|\n"
+ "(?P<context>@\\w+)|\n"
+ "(?P<meta>[a-zA-Z]+:[\\w-]*)";
final String string = "(A) Thank Mom for the meatballs @phone\n"
+ "(B) Schedule Goodwill pickup +GarageSale @phone\n"
+ "Post signs around the neighborhood +GarageSale\n"
+ "@GroceryStore Eskimo pies\n\n"
+ "Really gotta call Mom (A) @phone @someday\n"
+ "(b) Get back to the boss\n"
+ "(B) Submit TPS report\n\n"
+ "x 2011-03-03 Call Mom due:2010-01-02 again:thisOne\n\n"
+ "x 2011-03-02 2011-03-01 Review Tim's pull request +TodoTxtTouch @github\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}