import Foundation
let pattern = #"""
(?:^[ \t]*(?P<complete>x))|
(?P<priority>\(\w+\))|
(?:(?P<CoDate>\d{4}-\d\d-\d\d)[ \t]*(?P<CrDate>\d{4}-\d\d-\d\d)?)|
(?P<task>[\w']+(?:[.,; \t-]+[\w']+)*\b(?!:))|
(?P<Project>\+\w+)|
(?P<context>@\w+)|
(?P<meta>[a-zA-Z]+:[\w-]*)
"""#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive, .allowCommentsAndWhitespace])
let testString = #"""
(A) Thank Mom for the meatballs @phone
(B) Schedule Goodwill pickup +GarageSale @phone
Post signs around the neighborhood +GarageSale
@GroceryStore Eskimo pies
Really gotta call Mom (A) @phone @someday
(b) Get back to the boss
(B) Submit TPS report
x 2011-03-03 Call Mom due:2010-01-02 again:thisOne
x 2011-03-02 2011-03-01 Review Tim's pull request +TodoTxtTouch @github
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)