use strict;
my $str = '(A) Thank Mom for the meatballs @phone
(B) Schedule Goodwill pickup +GarageSale @phone
Post signs around the neighborhood +GarageSale
@GroceryStore Eskimo pies
Really gotta call Mom (A) @phone @someday
(b) Get back to the boss
(B) Submit TPS report
x 2011-03-03 Call Mom due:2010-01-02 again:thisOne
x 2011-03-02 2011-03-01 Review Tim\'s pull request +TodoTxtTouch @github
';
my $regex = qr/(?:^[ \t]*(?P<complete>x))|
(?P<priority>\(\w+\))|
(?:(?P<CoDate>\d{4}-\d\d-\d\d)[ \t]*(?P<CrDate>\d{4}-\d\d-\d\d)?)|
(?P<task>[\w']+(?:[.,; \t-]+[\w']+)*\b(?!:))|
(?P<Project>\+\w+)|
(?P<context>@\w+)|
(?P<meta>[a-zA-Z]+:[\w-]*)/mxip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}