const regex = new RegExp('(?:^[ \\t]*(?P<complete>x))|
(?P<priority>\\(\\w+\\))|
(?:(?P<CoDate>\\d{4}-\\d\\d-\\d\\d)[ \\t]*(?P<CrDate>\\d{4}-\\d\\d-\\d\\d)?)|
(?P<task>[\\w\\']+(?:[.,; \\t-]+[\\w\\']+)*\\b(?!:))|
(?P<Project>\\+\\w+)|
(?P<context>@\\w+)|
(?P<meta>[a-zA-Z]+:[\\w-]*)', 'gmi')
const str = `(A) Thank Mom for the meatballs @phone
(B) Schedule Goodwill pickup +GarageSale @phone
Post signs around the neighborhood +GarageSale
@GroceryStore Eskimo pies
Really gotta call Mom (A) @phone @someday
(b) Get back to the boss
(B) Submit TPS report
x 2011-03-03 Call Mom due:2010-01-02 again:thisOne
x 2011-03-02 2011-03-01 Review Tim's pull request +TodoTxtTouch @github
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}