using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?mi)Address\h+(\w+)\h+(\w+)\n\h*(\d+ \w+) (\w+) (\w+)\n(?:Phone\h+(.+)\n)?(?:Website\h+(.+)\n)?lat\. long\.\h+(.+)";
string input = @"Address Slangenburg 13
7608 RS Almelo Nederland
lat. long. 52.376536, 6.691050
Address Westeinde 26
1017 ZP Amsterdam Nederland
Phone +31 20 523 1030
Website https://www.Amsterdam.nl
lat. long. 52.359401, 4.898580";
RegexOptions options = RegexOptions.CultureInvariant;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}