import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?mi)Address\\h+(\\w+)\\h+(\\w+)\\n\\h*(\\d+ \\w+) (\\w+) (\\w+)\\n(?:Phone\\h+(.+)\\n)?(?:Website\\h+(.+)\\n)?lat\\. long\\.\\h+(.+)";
final String string = "Address Slangenburg 13\n"
+ " 7608 RS Almelo Nederland\n"
+ "lat. long. 52.376536, 6.691050\n\n"
+ "Address Westeinde 26\n"
+ " 1017 ZP Amsterdam Nederland\n"
+ "Phone +31 20 523 1030\n"
+ "Website https://www.Amsterdam.nl\n"
+ "lat. long. 52.359401, 4.898580";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}