re = /(?mi)Address\h+(\w+)\h+(\w+)\n\h*(\d+ \w+) (\w+) (\w+)\n(?:Phone\h+(.+)\n)?(?:Website\h+(.+)\n)?lat\. long\.\h+(.+)/
str = 'Address Slangenburg 13
7608 RS Almelo Nederland
lat. long. 52.376536, 6.691050
Address Westeinde 26
1017 ZP Amsterdam Nederland
Phone +31 20 523 1030
Website https://www.Amsterdam.nl
lat. long. 52.359401, 4.898580'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end