$re = '/(?mi)Address\h+(\w+)\h+(\w+)\n\h*(\d+ \w+) (\w+) (\w+)\n(?:Phone\h+(.+)\n)?(?:Website\h+(.+)\n)?lat\. long\.\h+(.+)/u';
$str = 'Address Slangenburg 13
7608 RS Almelo Nederland
lat. long. 52.376536, 6.691050
Address Westeinde 26
1017 ZP Amsterdam Nederland
Phone +31 20 523 1030
Website https://www.Amsterdam.nl
lat. long. 52.359401, 4.898580';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);