import Foundation
// WARNING: You included a flag that Swift doesn't support: u
// When this flag is set, it makes the pattern and subject strings to be treated as unicode.
// Swift already treats the pattern and subject strings as unicode by default, so including this flag is redundant.
let pattern = #"(?mi)Address\h+(\w+)\h+(\w+)\n\h*(\d+ \w+) (\w+) (\w+)\n(?:Phone\h+(.+)\n)?(?:Website\h+(.+)\n)?lat\. long\.\h+(.+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Address Slangenburg 13
7608 RS Almelo Nederland
lat. long. 52.376536, 6.691050
Address Westeinde 26
1017 ZP Amsterdam Nederland
Phone +31 20 523 1030
Website https://www.Amsterdam.nl
lat. long. 52.359401, 4.898580
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)