use strict;
my $str = 'Address Slangenburg 13
7608 RS Almelo Nederland
lat. long. 52.376536, 6.691050
Address Westeinde 26
1017 ZP Amsterdam Nederland
Phone +31 20 523 1030
Website https://www.Amsterdam.nl
lat. long. 52.359401, 4.898580';
my $regex = qr/(?mi)Address\h+(\w+)\h+(\w+)\n\h*(\d+ \w+) (\w+) (\w+)\n(?:Phone\h+(.+)\n)?(?:Website\h+(.+)\n)?lat\. long\.\h+(.+)/up;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}