using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=class=""four-column mosaicElement"")[\s\S]*?href=""\s*(https?[^\s]+)\s*""";
string input = @"<li class=""four-column mosaicElement"">
<a href=""https://example.com"" title=""Lorem ipsum"">
...
</a>
</li>
<li class=""four-column mosaicElement"">
<a href=""https://example.org"" title=""Lorem ipsum"">
<li class=""four-column mosaicElement"">
<a href="" https://example.org "" title=""Lorem ipsum"">
<li class=""four-column mosaicElement"">
<a href="" https://example.org "" title=""Lorem ipsum"">
...
</a>
</li>
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}