re = /(?=class="four-column mosaicElement")[\s\S]*?href="\s*(https?[^\s]+)\s*"/m
str = '<li class="four-column mosaicElement">
<a href="https://example.com" title="Lorem ipsum">
...
</a>
</li>
<li class="four-column mosaicElement">
<a href="https://example.org" title="Lorem ipsum">
<li class="four-column mosaicElement">
<a href=" https://example.org " title="Lorem ipsum">
<li class="four-column mosaicElement">
<a href=" https://example.org " title="Lorem ipsum">
...
</a>
</li>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end