const regex = /(?=class="four-column mosaicElement")[\s\S]*?href="\s*(https?[^\s]+)\s*"/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?=class="four-column mosaicElement")[\\s\\S]*?href="\\s*(https?[^\\s]+)\\s*"', 'gm')
const str = `<li class="four-column mosaicElement">
<a href="https://example.com" title="Lorem ipsum">
...
</a>
</li>
<li class="four-column mosaicElement">
<a href="https://example.org" title="Lorem ipsum">
<li class="four-column mosaicElement">
<a href=" https://example.org " title="Lorem ipsum">
<li class="four-column mosaicElement">
<a href=" https://example.org " title="Lorem ipsum">
...
</a>
</li>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}