use strict;
my $str = '<li class="four-column mosaicElement">
<a href="https://example.com" title="Lorem ipsum">
...
</a>
</li>
<li class="four-column mosaicElement">
<a href="https://example.org" title="Lorem ipsum">
<li class="four-column mosaicElement">
<a href=" https://example.org " title="Lorem ipsum">
<li class="four-column mosaicElement">
<a href=" https://example.org " title="Lorem ipsum">
...
</a>
</li>
';
my $regex = qr/(?=class="four-column mosaicElement")[\s\S]*?href="\s*(https?[^\s]+)\s*"/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}