import re
regex = re.compile(r"(?=class=\"four-column mosaicElement\")[\s\S]*?href=\"\s*(https?[^\s]+)\s*\"", flags=re.MULTILINE)
test_str = ("<li class=\"four-column mosaicElement\">\n"
"<a href=\"https://example.com\" title=\"Lorem ipsum\">\n"
"...\n"
"</a>\n"
"</li>\n"
"<li class=\"four-column mosaicElement\">\n"
"<a href=\"https://example.org\" title=\"Lorem ipsum\">\n\n"
"<li class=\"four-column mosaicElement\">\n"
"<a href=\" https://example.org \" title=\"Lorem ipsum\">\n\n"
"<li class=\"four-column mosaicElement\">\n"
"<a href=\" https://example.org \" title=\"Lorem ipsum\">\n"
"...\n"
"</a>\n"
"</li>\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")