#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(.*)(?:\bm\.)(.*)|(.*)"
Local $sString = "https://m.gsmarena.com/sony_xperia_5_iv-price-11838.php" & @CRLF & _
"https://redfm.ie/" & @CRLF & _
"https://en.m.wikipedia.org/"
Local $sSubst = "$1$2$3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)