import re
regex = re.compile(r"(.*)(?:\bm\.)(.*)|(.*)", flags=re.MULTILINE)
test_str = ("https://m.gsmarena.com/sony_xperia_5_iv-price-11838.php\n"
"https://redfm.ie/\n"
"https://en.m.wikipedia.org/")
subst = "$1$2$3"
result = regex.sub(subst, test_str)
if result:
print(result)