import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.*)(?:\\bm\\.)(.*)|(.*)";
final String string = "https://m.gsmarena.com/sony_xperia_5_iv-price-11838.php\n"
+ "https://redfm.ie/\n"
+ "https://en.m.wikipedia.org/";
final String subst = "$1$2$3";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}