$re = '/(.*)(?:\bm\.)(.*)|(.*)/m';
$str = 'https://m.gsmarena.com/sony_xperia_5_iv-price-11838.php
https://redfm.ie/
https://en.m.wikipedia.org/';
$subst = "$1$2$3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;