#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=(.+)\1+(.+)\2+$)(?!\1++$)(?=(.(?:(?-1)|(?=\2+$)).)$)(\1(?-1)?\2)$"
Local $sString = "ab" & @CRLF & _
"a" & @CRLF & _
"aaaaaaaaaaaaaaabbbbbbbb" & @CRLF & _
"bba" & @CRLF & _
"aaaacbbb" & @CRLF & _
"foobarfoo" & @CRLF & _
"foofoobar" & @CRLF & _
"" & @CRLF & _
"aaabbb" & @CRLF & _
"aabb" & @CRLF & _
"aaaaaaaabbbbbbbb" & @CRLF & _
"foofoobarbar"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")