import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=(.+)\\1+(.+)\\2+$)(?!\\1++$)(?=(.(?:(?-1)|(?=\\2+$)).)$)(\\1(?-1)?\\2)$";
final String string = "ab\n"
+ "a\n"
+ "aaaaaaaaaaaaaaabbbbbbbb\n"
+ "bba\n"
+ "aaaacbbb\n"
+ "foobarfoo\n"
+ "foofoobar\n\n"
+ "aaabbb\n"
+ "aabb\n"
+ "aaaaaaaabbbbbbbb\n"
+ "foofoobarbar";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}