using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=(.+)\1+(.+)\2+$)(?!\1++$)(?=(.(?:(?-1)|(?=\2+$)).)$)(\1(?-1)?\2)$";
string input = @"ab
a
aaaaaaaaaaaaaaabbbbbbbb
bba
aaaacbbb
foobarfoo
foofoobar
aaabbb
aabb
aaaaaaaabbbbbbbb
foofoobarbar";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}