# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(a\.b\(.*?\))/\1.c()/gm;t' <<< "a.b(param1=1);
a.b(param1=1, param2=2);
a.b();"