package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(a\.b\(.*?\))`)
var str = `a.b(param1=1);
a.b(param1=1, param2=2);
a.b();`
var substitution = "\1.c()"
fmt.Println(re.ReplaceAllString(str, substitution))
}