// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(a\.b\(.*?\))").unwrap();
let string = "a.b(param1=1);
a.b(param1=1, param2=2);
a.b();";
let substitution = "\\1.c()";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}