#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(a\.b\(.*?\))"
Local $sString = "a.b(param1=1);" & @CRLF & _
"a.b(param1=1, param2=2);" & @CRLF & _
"a.b();"
Local $sSubst = "\1.c()"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)