$re = '/(a\.b\(.*?\))/m';
$str = 'a.b(param1=1);
a.b(param1=1, param2=2);
a.b();';
$subst = "\1.c()";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;