using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(a\.b\(.*?\))";
string substitution = @"\1.c()";
string input = @"a.b(param1=1);
a.b(param1=1, param2=2);
a.b();";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}